// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)eventType\":\"(?<Status>.*)"#).unwrap();
let string = "{\"severity\":\"INFO\",\"logger\":\"is_lambda_cacm_cust_events\",\"thread\":\"main\",\"message\":{\"msg\":\"{MessageId: 294b3204-86bb-535e-8e15-6717adceafa6}\",\"eventId\":\"2395587\",\"retryCount\":0,\"name\":\"is_lambda_cacm_cust_events\",\"correlationId\":\"2395587\",\"eventType\":\"Client\",\"originator\":\"Lambda\",\"status\":\"Success\"}}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}