#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:remind me ).*? (to|that|about|its|it's)? ?(.*)$"
Local $sString = "remind me in 24 hours test" & @CRLF & _
"remind me in 24 hours to test" & @CRLF & _
"remind me to test" & @CRLF & _
"" & @CRLF & _
"E.g. These strings would work with your current pattern" & @CRLF & _
"two spaces after 'remind me' where the group fits in:" & @CRLF & _
"^(?:remind me ).*? (to...." & @CRLF & _
" ^ ^" & @CRLF & _
"remind me to test" & @CRLF & _
"remind me blabla to test" & @CRLF & _
"" & @CRLF & _
"one or three or more, no:" & @CRLF & _
"remind me to test" & @CRLF & _
"remind me to test" & @CRLF & _
"remind me bla bla to test" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")