package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:remind me ).*? (to|that|about|its|it's)? ?(.*)$`)
var str = `remind me in 24 hours test
remind me in 24 hours to test
remind me to test
E.g. These strings would work with your current pattern
two spaces after 'remind me' where the group fits in:
^(?:remind me ).*? (to....
^ ^
remind me to test
remind me blabla to test
one or three or more, no:
remind me to test
remind me to test
remind me bla bla to test
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}