re = /^(?:remind me ).*? (to|that|about|its|it's)? ?(.*)$/m
str = 'remind me in 24 hours test
remind me in 24 hours to test
remind me to test
E.g. These strings would work with your current pattern
two spaces after \'remind me\' where the group fits in:
^(?:remind me ).*? (to....
^ ^
remind me to test
remind me blabla to test
one or three or more, no:
remind me to test
remind me to test
remind me bla bla to test
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end