use strict;
my $str = 'remind me in 24 hours test
remind me in 24 hours to test
remind me to test
E.g. These strings would work with your current pattern
two spaces after \'remind me\' where the group fits in:
^(?:remind me ).*? (to....
^ ^
remind me to test
remind me blabla to test
one or three or more, no:
remind me to test
remind me to test
remind me bla bla to test
';
my $regex = qr/^(?:remind me ).*? (to|that|about|its|it's)? ?(.*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}