#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^-?(?:[1-9][0-9]{0,2})?$"
Local $sString = "-" & @CRLF & _
"0" & @CRLF & _
"1" & @CRLF & _
"9" & @CRLF & _
"11" & @CRLF & _
"10" & @CRLF & _
"19" & @CRLF & _
"20" & @CRLF & _
"21" & @CRLF & _
"99" & @CRLF & _
"100" & @CRLF & _
"101" & @CRLF & _
"111" & @CRLF & _
"123" & @CRLF & _
"157" & @CRLF & _
"180" & @CRLF & _
"199" & @CRLF & _
"200" & @CRLF & _
"999" & @CRLF & _
"1000" & @CRLF & _
"1999"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")