# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^-?(?:[1-9][0-9]{0,2})?$"
test_str = ("-\n"
"0\n"
"1\n"
"9\n"
"11\n"
"10\n"
"19\n"
"20\n"
"21\n"
"99\n"
"100\n"
"101\n"
"111\n"
"123\n"
"157\n"
"180\n"
"199\n"
"200\n"
"999\n"
"1000\n"
"1999")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.