re = /^-?(?:[1-9][0-9]{0,2})?$/m
str = '-
0
1
9
11
10
19
20
21
99
100
101
111
123
157
180
199
200
999
1000
1999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end