const regex = /^-?(?:[1-9][0-9]{0,2})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^-?(?:[1-9][0-9]{0,2})?$', 'gm')
const str = `-
0
1
9
11
10
19
20
21
99
100
101
111
123
157
180
199
200
999
1000
1999`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}