using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^-?(?:[1-9][0-9]{0,2})?$";
string input = @"-
0
1
9
11
10
19
20
21
99
100
101
111
123
157
180
199
200
999
1000
1999";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}