package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^-?(?:[1-9][0-9]{0,2})?$`)
var str = `-
0
1
9
11
10
19
20
21
99
100
101
111
123
157
180
199
200
999
1000
1999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}