// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^-?(?:[1-9][0-9]{0,2})?$").unwrap();
let string = "-
0
1
9
11
10
19
20
21
99
100
101
111
123
157
180
199
200
999
1000
1999";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}