import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-?(?:[1-9][0-9]{0,2})?$";
final String string = "-\n"
+ "0\n"
+ "1\n"
+ "9\n"
+ "11\n"
+ "10\n"
+ "19\n"
+ "20\n"
+ "21\n"
+ "99\n"
+ "100\n"
+ "101\n"
+ "111\n"
+ "123\n"
+ "157\n"
+ "180\n"
+ "199\n"
+ "200\n"
+ "999\n"
+ "1000\n"
+ "1999";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}