# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^0+(\d)|(\d)0+$/$1$2/gm;t' <<< "00001011100000
000
000000123
000000456000000000000
789000"