const regex = /^0+(\d)|(\d)0+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^0+(\\d)|(\\d)0+$', 'gm')
const str = `00001011100000
000
000000123
000000456000000000000
789000`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);