package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^0+(\d)|(\d)0+$`)
var str = `00001011100000
000
000000123
000000456000000000000
789000`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}