import Foundation
let pattern = #"^0+(\d)|(\d)0+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
00001011100000
000
000000123
000000456000000000000
789000
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)