use strict;
my $str = '00001011100000
000
000000123
000000456000000000000
789000';
my $regex = qr/^0+(\d)|(\d)0+$/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";