# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s+//gm;t' <<< " select * from expressions
where if(
'+' = @o := operation,
a + b,
if(
@o = '-',
a - b,
if(
@o = '*',
a * b,
a / b
)
)
) = c"