const regex = /\s+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+', 'gm')
const str = ` select * from expressions
where if(
'+' = @o := operation,
a + b,
if(
@o = '-',
a - b,
if(
@o = '*',
a * b,
a / b
)
)
) = c`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);