re = /\s+/m
str = ' select * from expressions
where if(
\'+\' = @o := operation,
a + b,
if(
@o = \'-\',
a - b,
if(
@o = \'*\',
a * b,
a / b
)
)
) = c'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result