#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s+"
Local $sString = " select * from expressions" & @CRLF & _
" where if(" & @CRLF & _
" '+' = @o := operation," & @CRLF & _
" a + b," & @CRLF & _
" if(" & @CRLF & _
" @o = '-'," & @CRLF & _
" a - b," & @CRLF & _
" if(" & @CRLF & _
" @o = '*'," & @CRLF & _
" a * b," & @CRLF & _
" a / b" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
" ) = c"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)