using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+";
string substitution = @"";
string input = @" select * from expressions
where if(
'+' = @o := operation,
a + b,
if(
@o = '-',
a - b,
if(
@o = '*',
a * b,
a / b
)
)
) = c";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}