package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s+`)
var str = ` select * from expressions
where if(
'+' = @o := operation,
a + b,
if(
@o = '-',
a - b,
if(
@o = '*',
a * b,
a / b
)
)
) = c`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}