use strict;
my $str = ' select * from expressions
where if(
\'+\' = @o := operation,
a + b,
if(
@o = \'-\',
a - b,
if(
@o = \'*\',
a * b,
a / b
)
)
) = c';
my $regex = qr/\s+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";