$re = '/\s+/m';
$str = ' select * from expressions
where if(
\'+\' = @o := operation,
a + b,
if(
@o = \'-\',
a - b,
if(
@o = \'*\',
a * b,
a / b
)
)
) = c';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;