# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[not,(\d+)\]/-\1/g;t' <<< "[not,35]
[not,5]"