$re = '/\[not,(\d+)\]/';
$str = '[not,35]
[not,5]';
$subst = "-\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;