package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[not,(\d+)\]`)
var str = `[not,35]
[not,5]`
var substitution = "-\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}