import re
regex = re.compile(r"\[not,(\d+)\]")
test_str = ("[not,35]\n"
"[not,5]")
subst = "-\\1"
result = regex.sub(subst, test_str)
if result:
print(result)