#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[not,(\d+)\]"
Local $sString = "[not,35]" & @CRLF & _
"[not,5]"
Local $sSubst = "-\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)