const regex = new RegExp('\\[not,(\\d+)\\]', 'g')
const str = `[not,35]
[not,5]`;
const subst = `-\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);