using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[not,(\d+)\]";
string substitution = @"-\1";
string input = @"[not,35]
[not,5]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}