import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<w:body>.*(<w:p>(.*)<\\/w:p>).*<\\/w:body>";
final String string = "<w:body>\n"
+ "<w:body>\n"
+ " <w:p>\n"
+ " <w:pPr>\n"
+ " <w:pStyle w:val=\"Style19\"/>\n"
+ " <w:jc w:val=\"center\"/>\n"
+ " </w:pPr>\n"
+ " <w:r>\n"
+ " <w:rPr>\n"
+ " <w:b/>\n"
+ " <w:bCs/>\n"
+ " <w:i/>\n"
+ " <w:iCs/>\n"
+ " <w:sz w:val=\"144\"/>\n"
+ " <w:szCs w:val=\"144\"/>\n"
+ " <w:lang w:val=\"en-US\"/>\n"
+ " </w:rPr>\n"
+ " <w:t>ONE!</w:t>\n"
+ " <w:br/>\n"
+ " <w:t xml:space=\"preserve\"> {NUM}</w:t>\n"
+ " </w:r>\n"
+ " <w:r></w:r>\n"
+ " </w:p>\n"
+ "</w:body>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}