use strict;
my $str = '<w:body>
<w:body>
<w:p>
<w:pPr>
<w:pStyle w:val="Style19"/>
<w:jc w:val="center"/>
</w:pPr>
<w:r>
<w:rPr>
<w:b/>
<w:bCs/>
<w:i/>
<w:iCs/>
<w:sz w:val="144"/>
<w:szCs w:val="144"/>
<w:lang w:val="en-US"/>
</w:rPr>
<w:t>ONE!</w:t>
<w:br/>
<w:t xml:space="preserve"> {NUM}</w:t>
</w:r>
<w:r></w:r>
</w:p>
</w:body>';
my $regex = qr/<w:body>.*(<w:p>(.*)<\/w:p>).*<\/w:body>/isp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}