// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?is)<w:body>.*(<w:p>(.*)<\/w:p>).*<\/w:body>").unwrap();
let string = "<w:body>
<w:body>
<w:p>
<w:pPr>
<w:pStyle w:val=\"Style19\"/>
<w:jc w:val=\"center\"/>
</w:pPr>
<w:r>
<w:rPr>
<w:b/>
<w:bCs/>
<w:i/>
<w:iCs/>
<w:sz w:val=\"144\"/>
<w:szCs w:val=\"144\"/>
<w:lang w:val=\"en-US\"/>
</w:rPr>
<w:t>ONE!</w:t>
<w:br/>
<w:t xml:space=\"preserve\"> {NUM}</w:t>
</w:r>
<w:r></w:r>
</w:p>
</w:body>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}