# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<w:body>.*(<w:p>(.*)<\/w:p>).*<\/w:body>"
test_str = ("<w:body>\n"
"<w:body>\n"
" <w:p>\n"
" <w:pPr>\n"
" <w:pStyle w:val=\"Style19\"/>\n"
" <w:jc w:val=\"center\"/>\n"
" </w:pPr>\n"
" <w:r>\n"
" <w:rPr>\n"
" <w:b/>\n"
" <w:bCs/>\n"
" <w:i/>\n"
" <w:iCs/>\n"
" <w:sz w:val=\"144\"/>\n"
" <w:szCs w:val=\"144\"/>\n"
" <w:lang w:val=\"en-US\"/>\n"
" </w:rPr>\n"
" <w:t>ONE!</w:t>\n"
" <w:br/>\n"
" <w:t xml:space=\"preserve\"> {NUM}</w:t>\n"
" </w:r>\n"
" <w:r></w:r>\n"
" </w:p>\n"
"</w:body>")
matches = re.search(regex, test_str, re.IGNORECASE | re.DOTALL)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.