#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?i)" & @CRLF & _
"^ " & @CRLF & _
"(?= [a-z] .{5,15} $ )" & @CRLF & _
"[a-z0-9]* -? [a-z0-9]+ " & @CRLF & _
"$"
Local $sString = "PeterParker" & @CRLF & _
"Peter-Parker" & @CRLF & _
"Peter-P-arker" & @CRLF & _
"Peter" & @CRLF & _
"PeterParker-" & @CRLF & _
"-PeterParker" & @CRLF & _
"1PeterParker" & @CRLF & _
"Peter Parker" & @CRLF & _
"PeterParkerSpiderMan"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")