import re
regex = re.compile(r"""
(?i)
^
(?= [a-z] .{5,15} $ )
[a-z0-9]* -? [a-z0-9]+
$
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("PeterParker\n"
"Peter-Parker\n"
"Peter-P-arker\n"
"Peter\n"
"PeterParker-\n"
"-PeterParker\n"
"1PeterParker\n"
"Peter Parker\n"
"PeterParkerSpiderMan")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")