import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)\n"
+ "^ \n"
+ "(?= [a-z] .{5,15} $ )\n"
+ "[a-z0-9]* -? [a-z0-9]+ \n"
+ "$";
final String string = "PeterParker\n"
+ "Peter-Parker\n"
+ "Peter-P-arker\n"
+ "Peter\n"
+ "PeterParker-\n"
+ "-PeterParker\n"
+ "1PeterParker\n"
+ "Peter Parker\n"
+ "PeterParkerSpiderMan";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}