using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)
^
(?= [a-z] .{5,15} $ )
[a-z0-9]* -? [a-z0-9]+
$";
string input = @"PeterParker
Peter-Parker
Peter-P-arker
Peter
PeterParker-
-PeterParker
1PeterParker
Peter Parker
PeterParkerSpiderMan";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}