use strict;
my $str = 'PeterParker
Peter-Parker
Peter-P-arker
Peter
PeterParker-
-PeterParker
1PeterParker
Peter Parker
PeterParkerSpiderMan';
my $regex = qr/(?i)
^
(?= [a-z] .{5,15} $ )
[a-z0-9]* -? [a-z0-9]+
$/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}