// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)(?i)
^
(?= [a-z] .{5,15} $ )
[a-z0-9]* -? [a-z0-9]+
$").unwrap();
let string = "PeterParker
Peter-Parker
Peter-P-arker
Peter
PeterParker-
-PeterParker
1PeterParker
Peter Parker
PeterParkerSpiderMan";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}