re = /(?i)
^
(?= [a-z] .{5,15} $ )
[a-z0-9]* -? [a-z0-9]+
$/mx
str = 'PeterParker
Peter-Parker
Peter-P-arker
Peter
PeterParker-
-PeterParker
1PeterParker
Peter Parker
PeterParkerSpiderMan'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end