#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<hour>\d+):(?<minute>\d+):(?<second>\d+),(?<msecond>\d+)"
Local $sString = "1" & @CRLF & _
"00:00:53,000 --> 00:00:57,000" & @CRLF & _
"<any text that may span multiple lines>" & @CRLF & _
"" & @CRLF & _
"2" & @CRLF & _
"00:01:28,000 --> 00:01:35,000" & @CRLF & _
"<any text that may span multiple lines>" & @CRLF & _
"" & @CRLF & _
"3" & @CRLF & _
"00:02:09,000 --> 00:02:14,000" & @CRLF & _
"<any text that may span multiple lines>" & @CRLF & _
"" & @CRLF & _
"4" & @CRLF & _
"00:02:14,000 --> 00:02:19,000" & @CRLF & _
"<any text that may span multiple lines>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")