// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?<hour>\d+):(?<minute>\d+):(?<second>\d+),(?<msecond>\d+)").unwrap();
let string = "1
00:00:53,000 --> 00:00:57,000
<any text that may span multiple lines>
2
00:01:28,000 --> 00:01:35,000
<any text that may span multiple lines>
3
00:02:09,000 --> 00:02:14,000
<any text that may span multiple lines>
4
00:02:14,000 --> 00:02:19,000
<any text that may span multiple lines>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}