using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<hour>\d+):(?<minute>\d+):(?<second>\d+),(?<msecond>\d+)";
string input = @"1
00:00:53,000 --> 00:00:57,000
<any text that may span multiple lines>
2
00:01:28,000 --> 00:01:35,000
<any text that may span multiple lines>
3
00:02:09,000 --> 00:02:14,000
<any text that may span multiple lines>
4
00:02:14,000 --> 00:02:19,000
<any text that may span multiple lines>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}