import Foundation
let pattern = #"(?<hour>\d+):(?<minute>\d+):(?<second>\d+),(?<msecond>\d+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1
00:00:53,000 --> 00:00:57,000
<any text that may span multiple lines>
2
00:01:28,000 --> 00:01:35,000
<any text that may span multiple lines>
3
00:02:09,000 --> 00:02:14,000
<any text that may span multiple lines>
4
00:02:14,000 --> 00:02:19,000
<any text that may span multiple lines>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)