package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<hour>\d+):(?<minute>\d+):(?<second>\d+),(?<msecond>\d+)`)
var str = `1
00:00:53,000 --> 00:00:57,000
<any text that may span multiple lines>
2
00:01:28,000 --> 00:01:35,000
<any text that may span multiple lines>
3
00:02:09,000 --> 00:02:14,000
<any text that may span multiple lines>
4
00:02:14,000 --> 00:02:19,000
<any text that may span multiple lines>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}