$re = '/(?<hour>\d+):(?<minute>\d+):(?<second>\d+),(?<msecond>\d+)/';
$str = '1
00:00:53,000 --> 00:00:57,000
<any text that may span multiple lines>
2
00:01:28,000 --> 00:01:35,000
<any text that may span multiple lines>
3
00:02:09,000 --> 00:02:14,000
<any text that may span multiple lines>
4
00:02:14,000 --> 00:02:19,000
<any text that may span multiple lines>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);